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ABOUT RELEASE NOTES AND OTHER DOCUMENTATION 
Use release notes to find out about new functions or enhancements to existing functions for 
this release. 
 
For more details about all functions, use the product’s Help documentation (Help>Help 
Topics, or press ALT+F1). 
 
For documentation that focuses on task-oriented needs, use the tutorials. These are available 
in the product’s Help system (Help>Tutorials). 
 
The web site has other product and company information (www.kubotekusa.com).  
 

NOTE ON HELP SYSTEM: Starting with this release, KeyCreator Help is an HTML 
Help system rather than a WinHelp Help system. For details, see HTML Help with This 
Release, on page 36. 
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NEW FUNCTIONS 
This release adds the new functions explained below. 
 

OBJ Export 
Location: File>Export>OBJ. With this release, you can export the model or selected 
entities as a.obj file. 
 

Name Function Moved from Composite to Entities Menu 
Location: Edit>Entities>Name. This release moves the Name function from the 
Tools>Composite menu to the Edit>Entities menu. The topic name in KeyCreator Help for 
this function has been changed from Composite Name to Name. 
 

Modeless Change Attributes 
Location: Edit>Entities>Attributes by Single Select. This function displays a modeless 
version of the Edit>Entities>Attributes by Selection dialog. This means that you do not 
have to select OK to close the dialog before selecting the entities to change. Rather, select 
the desired attributes in the dialog, and then click an entity in the viewport. The entity 
immediately changes to the selected attributes. The dialog stays open for the duration of the 
function so you can easily select different attributes for the next entity.  
 

Phong Shaded Rendering 
Location: View>Render>Phong Shaded. This function allows you to display a solid 
model with a shaded representation. It is more accurate and has fewer artifacts than the 
View>Render>Gouraud Shaded function. See the related Smooth Shaded Now Named 
Gouraud Shaded on page 14.  
 

Shadow Map 
Location: View>Render>Shadow Map. Causes shadows to be drawn on faces in the 
model. This function is available only when using the Direct3D driver.  
 

Reflection Plane 
Location: View>Render>Reflection Plane. Causes a reflection of the model to be drawn 
below the model.  
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Smart Trim Functions 
Location: Modify>Trim>SmartSingle and Modify>Trim>SmartBoth. This release 
provides two "smart" trim functions. To understand their use, it is helpful to compare them 
with the Modify>Trim>Both function (which was available before this release and still is 
available). With the latter function, trim is accomplished by selecting explicitly the two 
desired entities involved in the trim. But with the smart functions, it is only necessary to 
select one entity. KeyCreator then automatically selects the second, intersecting, entity 
nearest to where you clicked on the first entity. So the location where you click on the first 
entity is crucial in determining which second entity KeyCreator selects automatically for the 
trim operation.   
 
Here is the difference between SmartSingle and SmartBoth. SmartSingle allows you to 
select an entity, and the function automatically trims it to its intersection with the closest 
entity. Note this special case: When a closed entity is selected, the function looks for a 
second intersection with another (third) entity, and trims the selected entity against two 
intersecting positions (like Trim>Double). The function fails if any of the two intersections 
is not found. 
 
SmartBoth does what SmartSingle does (trim the selected entity to the intersection of its 
closest neighbor) and additionally it trims the closest entity to that same intersection position 
as well. Note this special case: If both the selected entity and its closest neighbor are closed 
entities, the function defaults to a trim single of the selected (closed) entity, looking for and 
trimming against two distinct points of intersection. It ignores trimming the closest entity.    

Plane to Surface Function Added to Warp Menu 
Location: Modify>Warp>Plane to Surface 
This function allows you to warp a set of bodies from a planar surface to a non-planar 
one. For example, you could use this function as you design a tire tread on a flat 
surface and then warp it to a revolved surface. Or, you are designing a shoe tread 
flat and then use this function to warp to the sole of a shoe. Still another example 
is to warp lettering around an object. 
 
The Warp Plane to Face dialog, shown below, is available in this function. If you find that 
the orientation of the bodies is not what you had expected, you can use the dialog to flip the 
warped bodies about their X-, Y- and Z-axes. Also, you can rotate them about the Z-axis by 
entering angles in the Plane rotation edit field. 
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Hole Table to CSV 
Location:Detail>Notes>Hole Table to CSV 
This new function exports the information in a hole table to a .csv (Comma Separated 
Value) file. This capability also is made available through the Generic Edit for a hole table 
when you click the CSV Export button on the Hole table formatting pane of the Hole 
Table dialog. Note that the button appears on this pane only when you are editing a hole 
table.     
 

Restyle Detail Entities 
Location: Detail>Restyle Detail Ents>Lines and Detail>Restyle Detail Ents>Tolerance. 
This release adds Restyle Detail Ents (that is, Restyle Detail Entities) to the Details menu. 
Restyle Detail Ents has two subfunctions: Lines and Tolerance. Their dialogs are shown 
below. As you can see in the dialogs, the Lines function allows you to modify how the detail 
lines of a dimension are displayed, and the Tolerance function allows you to modify the 
tolerance of a dimension.  
 

 
 

 
 

Transform-Mate Moved to Transform Menu 
Location: Transform>Mating 
This release moves the Transform-Mate functions from the separate Qwins CDE (located on 
the Add-Ins menu) to the KeyCreator Transform menu. The functions are called "Mating" 
on the Transform menu, as shown below. These are useful for moving or copying existing 
geometry so that it is aligned with other geometry. The top seven on the menu (starting with 
"Position") are move functions, and the lower seven (starting with "Position Copy) are copy 
functions. See Transform Mating in Help for details.  
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Projected Instance  
Location: Layout>Projected Instance. This function allows you to create a projected 
instance of a drawing instance from a selected quadrant in the drawing instance. The 
function also allows you to create an isometric of a drawing instance, when you select from 
the top right in the drawing instance. In either case, the projected instance has all the same 
settings as the original instance. See Projected Instance in KeyCreator Help for more details. 
 

Convert to Reference  
Location: Assembly>Convert to Reference. This new addition to the Assemblies menu 
has the same functionality as the existing File>Export>KeyCreator Part function, when 
the Replace Entities with a Part Reference and Store the relative path to the referenced 
part (if possible) options are selected on the Export New Part Options dialog, shown 
below.  (You can display that dialog by clicking File>Export, then following the prompts 
on Conversation Bar, and then clicking the Options button.) 
 
The Convert to Reference function is a one-step alternative to the 
File>Export>KeyCreator Part function. Convert to Reference does not require opening 
the Options dialog and confirming that the correct options are selected.  
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Ability To Display Details through Part References Added  
Location: Assemblies>Include Detail Entities. This release adds the Include Detail 
Entities function to the Assemblies menu, and the related 

 Include Detail Entities in Part Reference Display check box to the Options pane 
of the Creating a New Part Reference dialog (Assemblies>Create Reference>select 
file>Options), and  

 Display Details column to the Part Reference pane of the Parts Splitter 
 
This allows a part reference to display details such as notes, labels, dimensions and 
crosshatches from the referenced part.   
 

ENHANCED FUNCTIONS 
This release enhances several functions, as explained below.  

Option Added to Units/Tolerances Pane of Properties Dialog 
Location: File>Properties>Units/Tolerances. This release adds the following option to the 
Units/Tolerances pane as shown below: 
 
Edge/Curve Normal Deviation: 
Allows you to define the tessellation for an arc, conic, spline and NURBS. It is the largest 
angle allowed between adjacent line segments in the tessellated representation.  
 
Note that, in this release, the name of the Normal Deviation (degrees) option on this dialog 
was changed to Solid/Sheet Normal Deviation (degrees): same function as previous 
release. 
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Option Added to DXF and DWG Import Dialog 
Location: File>Import>AutoCAD DXF and File>Import>AutoCAD DWF. As shown 
below, this release adds the Put AC layers on sub-levels of active level check box on the 
Import Options dialog for importing an AutoCAD DXF or DWG file. ("AC" in the check 
box name stands for "AutoCAD.") When you select this option, the layer structure of the 
AutoCAD file remains intact. The layers are placed as sublevels under the currently active 
level in KeyCreator. (Levels are visible in the KeyCreator Part Splitter.) 
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Option Added to DXG and DWG Export Dialog 
Location: File>Export>AutoCAD DXF then click the Options button, and 
File>Export>AutoCAD DWG then click the Options button. As shown below, this release 
adds the Export all levels to a single AC layer check box to the Export Options dialog. 
("AC" in the name of this check box stands for "AutoCAD.") When you select this option, 
all of the geometry in the KeyCreator file is flattened to a single layer in the exported file. 
This is useful for exporting layouts.   

 

 

 

 

 

 

 

 

 

  

 

Options Added to PDF Export 
Location: File>Export>PDF. This release adds options to the PDF Export Options 
dialog, explained and shown below.  
 
Scale determines the ratio of part size to paper size. Point size specifies the size of a printed 
point entity. Selecting a print configuration in the Use printer configuration field causes 
the applicable settings of the Print/Plot configuration (Tools>Options>Print/Plot) to be 
used for the export. For details on all options on the PDF Export Options dialog, see PDF 
Export in KeyCreator Help. For information on print configuration, see Print/Plot and 
related links in KeyCreator Help.  
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Smooth Shaded Now Named Gouraud Shaded 
Location: View>Render>Gouraud Shaded. With this release, the function previously 
called Smooth Shaded, under View>Render, is now called Gouraud Shaded. The function 
remains the same: only the name has changed. See the related Phong Shaded Rendering on 
page 6.  
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New Dialog Added for Cutting Plane Trim Dialog 
Location: View>Cutting Plane>choose plane>Trim, and View>Cutting Section. This 
release adds the Cutting Plane Trim dialog shown below. This dialog allows you to 

 Specify either a trim or break operation 
 Create lines and curves at the intersection of solids and cutting plane 
 Create hatch at the intersection of solids and cutting plane. As the hatch, you can 

select pattern, angle, spacing or offset. 
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Options Added to the Create a Sheetmetal Flange Dialog 
Location: Create>Solid Feature>Sheetmetal Flange. This release adds three radio buttons 
and a check box to the dialog, as shown below.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 
No Bend Offset, Offset by Bend Radius, Offset by Bend Radius + Thickness – These 
options allow the start of the bend to be offset backward. This allows for common 
sheetmetal operations where you want the sheetmetal part to maintain its dimensions (as 
opposed to building the part outward). The figure below illustrates each of these selections, 
respectively. The line in the figure corresponds to the face originally selected to create the 
flange. The No Bend Offset option matches the behavior of previous releases. 
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Bend to Face. See the before and after examples below. This option allows you to select 
another face while creating the flange. The flange angle and offset are automatically set to 
cause the face of the flange to be close and parallel to the selected face. A slight gap is left 
between the two faces so that the modeler will not attempt to merge the two. 
 
Before: 

 
 
After: 
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CPlane for "CP/Depth" (on Plane Definition Menu) Selectable from 
List 
Location: Various, such as View>Display View. This release adds the By List button, 
shown below, on the Conversation Bar for the CP/Depth option. The By List button allows 
you to select the CPlane from the CPlane Selection List dialog, instead of having to key-in 
the CPlane number.  
 

 Click View>Display View>CP/Dpth. The By List button appears, as shown below.  

 
 

 Click the By List button. The CPlane Selection List dialog appears, as shown 
below. 

 

 
 

 Select the desired CPlane from the list. The selection applies to the model. 
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Option Added to Solids Trim/Break Dialogs  
Location: Modify>Solids Trim/Break>Curve, Modify>Solids Trim/Break>Sheet 
Body/Faces and Modify>Solids Trim/Break>Plane. This release adds the Select Multiple 
Solids to Trim or Break check box to the dialogs that appear for each of the three functions 
Curve, Sheet Body/Faces and FPlane. The example dialog below is for Modify>Solids 
Trim/Break>Curve. 
 

 
 
When selected, this option allows you to select multiple solids/sheets to trim. Once you click 
OK, you are prompted for the trimming entity/entities. The next step is to select one or more 
solids/sheets to trim. 
 
When cleared (default), after you click OK, you are prompted for the trimming entities. The 
next step allows you to select one solid/sheet to trim/break. Once the operation is complete, 
you are prompted to select another solid/sheet to trim. If you are done trimming, selecting 
the ESC key exits the function. 
 
Before this release, you were asked to select the solid/sheet to trim/break, followed by the 
selection of trimming entities, after which the function automatically exited. 
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Icons Added To Buttons on Edit Dialog 
Location: Modify>Solid Feature>Hole. This release changes the appearance of buttons 
located on the Edit dialog, as shown below. These icons are taken from the Tools>Feature 
menu. The change is aesthetic only: it has no affect on the functions of the buttons. 
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Selection Added to Allow Leader Elbows 
Location: Detail>Symbol>Geometric Tolerance Symbol. This release adds the 
Horizontal/Vertical Segments selection to the Leader Type field list on the Options pane 
of the Create a New GeoTol dialog, as shown below.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
As illustrated below, selecting Horizontal/Vertical Segments allows the leader line to have 
one or two elbows, depending on where you place the leader in the KeyCreator viewport.  

 0.005

0.005 

Elbows 
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Get from Existing Entity Button Added to Detail Options Panes 
Location: Detail>Settings>Settings. This release adds the Get from existing entity button 
to the pane of each top-level node of the Detail Options dialog (Global, Detail entities, 
Linear dimensions, Circular dimensions, Angular dimensions, Ordinate dimensions 
and ArcLength dimensions). The button is illustrated below. If you already have 
dimensions on the currently displayed part, this button allows you to use these to set default 
settings for that part. 
 
 
 
 
 
 
 
 
 
  
 
 
 
 
 
 
 
 
 
 
 

 

Active Instance Function Removed 
Location: Layout>Active Instance. This release removes the Active Instance functionality. 
The presence of an active instance often resulted in confusion when users tried to use layout 
functions. It often resulted in unexpected results because there was no active instance, or it 
was set to a different instance than the one the user was trying to modify. The three 
functions that used Active Instance (namely, Detail>Crosshatch, Detail>Detail 
Lines>Centerline and Edit>Entities>Attributes by Selection) instead of explicitly asking the 
user to select an instance now have a '"select drawing instance" prompt on the Conversation 
Bar in layout mode. Because of the removal of Active Instance, the Active Instance Border 
term on the Color/Attributes pane of the Properties dialog 
(File>Properties>Color/Attributes) is now named Layout Border. The Inactive Instance 
Border term on the same pane is now named Instance Border.  
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Rendering Pane Added for Part Reference 
Location: Assemblies>Create Reference>Rendering and 
Edit>Entities>Edit>Rendering. This release adds the Rendering pane to the Create a 
New Part Reference dialog, shown below. (For a part reference, the Rendering pane also is 
added to the Editing Part Reference dialog.) This pane allows you to select the desired 
mode for rendering the part reference or to select the Set Transparency check box and set 
the desired degree of transparency (0 to 100). When creating a part reference, you can select 
the desired rendering using Assemblies>Create Reference>Rendering. When editing a 
part reference, use Edit>Entities>Rendering. 
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Message Added when Lightweight Does Not Occur 
Location: Assemblies>Lightweight, and Part Splitter>Part References>then select 
Lightweight for the reference. With this release, when you attempt to apply the Lightweight 
function to a part reference and the function does change the part to lightweight, a message 
appears indicating this. As shown below, with the message, in the Lightweight column of 
the Part Reference pane of the Parts Splitter, the check box in the part's row is shown 
unavailable (gray). Usually, the problem is that the Streamed option on the Level Sets pane 
of the Parts Splitter is not selected, as the message indicates. 
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Make Relative Button Added to Create Template Dialog  
Location: Tools>BOM and Table>Create Template. This release adds the Make 
Relative button on the dialog shown below that appears when you select the Create 
Template function. The button allows you to make the template file path relative to the part 
(that is, to the open .ckd file).      
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Buttons Added to Create BOM Dialogs  
Location: Tools>BOM and Table>Create BOM. This release adds buttons to several 
dialogs that appear when using the Create BOM function. It adds the Make Relative button 
to the Edit Category Template dialog, shown below, which appears when you click the 
Add button on the BOM dialog. See Button Added to Create Template Dialog above for an 
explanation of this button.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
The release adds the Print file list button to the NEWBOM pane of the BOM dialog. This 
button prints a report like that shown below. The report indicates the files used by all the 
BOMs for the current part. 
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The release adds the Move Up, Move Down and Add V. Obj from item buttons to the 
Data pane of the BOM dialog, as shown below. Move Up and Move Down allow you to 
determine the order in which items appear on the BOM. Clicking Add V. Obj from item 
displays the same dialog that appears when you select that Tools>BOM and Table>Create 
Virtual Object function. This dialog allows you to generate virtual objects on the BOM.      
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Options Dialog Panes Changed from Tabs to Tree Structure  
Location: Tools>Options. This release makes changes to the Set Configuration Options 
dialog to make it have a tree structure. Examples of the previous and new panes, showing 
the Saving pane selected as the example, are shown below. For the appearance and details of 
each pane, see the Set Configuration Options Panes topic in Help. 
 
Before this release: 
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New with this release: 
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Options Added to Position Pane of Set Configuration Options 
Dialog 
Location: Tools>Options>Position. This release adds the options indicated below. 
Cutpoint allows you to snap to the intersection of a wireframe entity (line, polyline, arc, 
conic, spline, NURBS) and cutting plane. When you select the Display Position Menu 
Option Indicator check box, the Use custom settings for position menu option indicator 
check box becomes available. This allows you to configure the custom settings shown under 
the check box for the position menu option indicator. 
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Error Message and Reset Button Added to Structural Shapes 
Dialog  
Location: Tools>Structural Shapes. This release adds The entered values do not make a 
valid beam error message to the Structural Shapes dialog, plus a Reset button to it, as 
shown below. The dialog allows you to enter values that do not create a valid shape. But 
when you do so, this error message and the Reset button appear. Clicking the Reset button 
restores the last set of valid values in the dialog and makes the error message disappear. 
(Prior to this release, when you entered an invalid value in a field, KeyCreator displayed an 
error message. After you cleared the error message, the invalid value in the field was 
changed back to the original value.) 
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Record KXL Macro Supports More Functions  
Location: Add-Ins>Record KXL Macro. Beginning with this release, the Record KXL 
Macro function supports the following functions: 
 
Modify>Trim: 
Both 
Divide 
Double 
First 
Modal 
SmartSingle 
SmartBoth 
Position 
 
 
Modify>Break: 
Both 
Divide 
Double 
First 
Modal 
Position 
 
Modify>Fillet: 
Trim 
No Trim 
 
Modify>Chamfer: 
Trim 
No Trim 
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Options Added to Display Pane of Set Configuration Options 
Dialog  
Location: Tools>Options>Display. This release adds the following options to the Display 
pane as shown below: 
 
Full Screen: When selected, the anti-aliasing applies to everything displayed. 
Enable Culling for Display: When selected, solids and shells whose pixel size is less than 
the value specified in the Threshold field are not displayed.  
Enable Culling for Rotation: When selected, solids and shells whose pixel size is less than 
the value specified in the Threshold field are not displayed during model rotation. 
Text Greeking:  When selected, KeyCreator substitutes a grid of lines for displayed True 
Type text that is less than the point size specified in the Limit field. (1 point – 1/72 inch). 
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NEW SDK FUNCTIONS 
To see any new SDK functions for this release, see the SDK Help. To do this, run the install 
program (setup.exe) located in the Debug folder on the Kubotek KeyCreator product CD. 
Then, click the following Help file: x/SDK/DOCS/SDK.hlp, where "x" is the install folder. 
Then click the What's New in the KeyCreator.sdk link.  

NEW KXL FUNCTIONS 
To see any new KXL functions for this release, see the product’s KXL Help (Help>KXL 
Help>What's New>New Functions for KC8.0). Note that, if you are running KeyCreator 
with the Windows Vista operating system, to view KXL Help you must install the Windows 
Help program, whose filename is WinHlp32.exe. Follow the download instructions at 
http://www.microsoft.com/downloads/details.aspx?FamilyId=6EBCFAD9-D3F5-4365-
8070-334CD175D4BB&displaylang=en. 
This is necessary because the Windows Vista operating system does not include 
WinHlp32.exe, the program necessary to read WinHelp files. (Previous Windows 
operating systems include this file.) 
 
 

DOCUMENTATION ONLY 
The following information is relevant to documentation only. 

HTML Help with This Release  
Starting with this release, the Help system is HTML based rather than WinHelp based. (This 
eliminates the need for users who have the Vista operating system to download and install 
the Windows Help program, whose filename is WinHlp32.exe. The Windows Vista 
operating system does not include WinHlp32.exe, the program necessary to read 
WinHelp files. Previous Windows operating systems include this file.) You will notice some 
changes in the Help interface but these are minimal and intuitive to those familiar with the 
previous (WinHelp) system.  
 
The KeyCreator tutorial Help system also is HTML based with this release.  
 
As explained under New KXL Functions above, KXL Help still uses WinHelp. 
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Printout of KeyCreator Help System Available  
The KeyCreator Help system is available on the product DVD at the location 
Documentation/Printed_KeyCreatorHelp_Release80.pdf. This approximately one-
thousand page document was generated from the Help system and then converted to 
a PDF. It is provided for your convenience. However, due to the size, no attempt was 
made to change the Help system to accommodate perfectly this printed document. 
Thus, there are some imperfections in this document, including occasional formatting 
issues and references to links that apply only in Help. 
 
 

MISCELLANEOUS 

Supported Translators 
The table below identifies the translator versions that KeyCreator 8.0 supports. The term 
“to” means “up to and including.” (Bold under a column heading indicates a change for this 
release: so this release makes no change.) 
 

File Format Direction Supported File 
Versions 

Imports/Exports as 
Assembly File? 

Import No ACIS 
Export 

1.5 to R18 
No 

Import No CATIA V4 
Export 

4.1.9 to 4.2.4 
No 

Import V5 R2 to V5 R18 Yes CATIA V5 
Export V5 R6 to R18 Yes 
Import All Versions to 2007 No 

DWG/DXF Export R12 to R14, 2000, 2002, 
2004 to 2006 No 

Import All Versions to 5.3  Yes IGES 
Export 5.3 Yes 

Part Files: 6 to 11, 2008 N/A AutoDesk 
Inventor Import Only 

Assembly Files: 11, 2008 Yes 
Import 10.0 to 19.0.172 Yes Parasolid 
Export 12.0 to 19.0.172 Yes 

Pro/ENGINEER Import Only 16 to 2001, Wildfire 1 to 3 Yes 
SolidWorks Import Only 96-2008 Yes  

Import Yes STEP 
Export 

AP203, AP214 
Yes 

Unigraphics Import Only 11 to 18, NX1 to NX5 Yes 
CADL 19 Export Only Up to CADKEY 19 No 
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Server License Failed Dialog 
With this release, if you try to use a KeyCreator floating license while all are being used, the 
All licenses for KeyCreator are in use dialog appears, like that shown below. As you can 
see, this dialog identifies who is using the licenses, their machine name and other related 
information, and provides a Retry button.  
 

 
 

Support for Pro/E Assembly Cut Feature 
Location: File>Import>Pro/E. With this release, flat translation and translation as internal 
or external references now support assembly cut features. These are features that are created 
in Pro/E at the assembly level, by subtracting tools from part references. This has no user-
interface effect. (Previous releases either ignored the tools or brought them in as is without 
generating the features.) 

Handling Selected Profile Entities Improved 
Location: Create > Swept Solid > Extrude, Create > Swept Solid > Revolve, Create > 
Swept Solid > Sweep, Create > Solid Feature > Boss, Create > Solid Feature > Pocket 
Create > Surfaces > Boundary Curves. This release improves the handling of selected 
profile entities. Included in these improvements are 

 Closed loops are now inferred from profiles 
 The functions above (beside "Location") are more tolerant of gaps. Previous releases 

required that there be no gaps larger than 1.0e-06.  
   

Name Function Moved to Entities Menu 
Location: Edit>Entities>Name. This release moves the Name function from the 
Tools>Composite menu to the Edit>Entities menu. The topic describing the function in 
KeyCreator Help is now Name, instead of Composite Name. 
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Display Performance Improved 
This release improves display performance. The table below shows an example of improved 
benchmark results for the Hardware OpenGL driver. (Actual values for your system could 
vary from those shown.)  The term "fps" means frames per second. This refers to the number 
of times per second KeyCreator can rotate the view of the model and then perform a full 
update of the screen. 
 

Item Release 7.5 Release 8.0 
10000 lines 127 fps 214 fps 
10000 arcs 37 fps 192 fps 
10000 ellipses 33 fps 192 fps 
10000 polylines 101 fps 212 fps 
10000 splines 25 fps 101 fps 

 
Also, the following options have been added that improve display performance: 
 

 Edge/Curve Normal Deviation on the Units/Tolerances pane of the Properties 
dialog. See Options Added to Units/Tolerances Pane of Properties Dialog on page 
10 for a description. 

 Enabling Culling for Display, Enabling Culling for Rotation and Enable Text 
Greeking on the Display pane of the Set Configuration Options dialog. See 
Options Added to Display Pane of Set Configuration Options Dialog on page 35 for 
descriptions.  

Direct3D Driver Requires Software Install for Windows 2000 or XP 
The Driver Type field on the Display pane of the Set Configuration Options dialog allows 
you to select the desired graphics driver. (Tools>Options, then click the Display node) As 
explained in KeyCreator Help, in the Display topic, one of these selections is Direct3D. To 
use the Direct3D driver with the Windows 2000 or Windows XP operating system, you must 
install the Direct3D End-User Run Time software. This software is available on the product 
DVD in the following directory: Release/DirectX. The file is named DXSETUP.exe. 
Double-click this file and follow the prompts to install it.  

Unsaved Construction Plane Now CP=DV 
With Release 8.0.1, if a part (.ckd) file is saved and closed, while the active Construction 
Plane (CPlane) is unsaved, the CPlane will be in CP=DV mode when the part is reopened. 
Previous to this release, the CPlane was in CP=1 mode when the part was reopened. For 
information on setting and saving a CPlane, see the Set Construction Plane topic in 
KeyCreator Help.  
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Extract-Profile CDE Added 
This release adds the Extract-Profile function. The function creates a profile from selected 
entities, after trimming them automatically. 

Starting Extract Profile 
You can start Extract-Profile using either of the following procedures: 
 
To Display the Extract-Profile Palette 
1. Click Add-Ins>CDE Open. The Select a CDE to Open dialog appears. 
2. Select qw_extractprofile.cde and click Open. The Qwins palette appears. 
3. Click the Extract Profiles from entities button on the Qwins palette. Proceed to 

Using the Function below. 
 

To Select from the Qwins Menu 
Click Add-Ins>Qwins>Qwins>Extract Profile. Proceed to Using the Function 
below. 

Using the Function 
1. Specify active level. 
2. Select the first entity. 
3. Specify the start point on the first entity. (You can skip this by pressing the 

ENTER key.) 
4. Select the second and the subsequent entities.  
5. Specify the end point on the last entity. (You can skip this by pressing the 

ENTER key.) 
6. If the result profile becomes OPEN, specify 

 Add a line to close, or 
 Leave it open 

If it is closed, this process is automatically skipped. 
7. Specify the attributes. 

 
Notes: 
1. Selectable entities are 

 Line, Circle/Arc, Conic, Polyline, Spline, NURBS (open or closed) 
 Edges of solid or other entities are selectable 

2. Only the intersections in 3D space are recognized 
3. Line, Arc and Conic are automatically extended to create the intersection 
4. When the entities are trimmed, the selected portion will remain 
5. Backup is possible, with Undo of shape 
6. If the command is aborted by ESC, all the intermediate results are cancelled 
7. Specifying the ActiveLevel: 

 Value 0 means the current active level 
 Nested level can be specified (ex. 10.1.1) 
 Negative value brings ActiveLevel back to the previous one after finishing 

the command 
8. Specifying Attributes: 
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 "Entity" button = Attributes are kept the same as the original entities selected 
 "System" button = Attributes are the same as the current system Attributes 

setup 
9. If the first and/or the last entities are "closed," the process of specifying the start 

and end points cannot be skipped 
10. When this command is successfully finished, the extracted profile chain is kept 

as PreSelected, so that the commands, such as Extrude, can use this pre-selected 
profile. This PreSelection can be cancelled with the ESC key. This is effective 
only if "PreSelection" option is set ON. 

11. Entities should be selected at the vicinity of the intersection point, and aimed at 
the portion to be kept. (If the selection position is not appropriate, unexpected 
trimming will occur.) 

12. For a curved entity, which may intersect with the next element at multiple 
locations, the closest intersection to the selected position will be chosen as the 
intersection to the next. 

13. This command can be Backed Up to the beginning, by pressing the F10 key 
several times. 

14. While specifying the attributes, pressing the ESC key will abort the command 
and all the process of this command is undone. This command is completed 
when and only when you click either the Entity or System button.
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